$re = '/_UK/m';
$str = '
/Folder_UK
/Folder_UK/
/Folder_UK/Folder2/
/FolderX/Folder_UK
/FolderX/Folder_UK/
/FolderX/Folder_UK/Folder2/
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;