const regex = /color:\s*+(?!(?:transparent|inherit)(?:;|$))[^@;\n][^;\n]*;?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('color:\\s*+(?!(?:transparent|inherit)(?:;|$))[^@;\\n][^;\\n]*;?', 'gm')
const str = `I want to capture all colors that are not "transparent", "inherit" or starts with an "@" character.
should be captured
--------------------------
color: blue;
color:red3434;
color: red3434;
color: #00FF00;
color: #F0F;
color: face(@B23);
should not be captured
--------------------------
color: transparent;
color:@transparent;
color: @transparent;
color:inherit;
color: @B23;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}