re = /color:\s*+(?!(?:transparent|inherit)(?:;|$))[^@;\n][^;\n]*;?/m
str = 'I want to capture all colors that are not "transparent", "inherit" or starts with an "@" character.
should be captured
--------------------------
color: blue;
color:red3434;
color: red3434;
color: #00FF00;
color: #F0F;
color: face(@B23);
should not be captured
--------------------------
color: transparent;
color:@transparent;
color: @transparent;
color:inherit;
color: @B23;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end