using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^color:(?!@|transparent|inherit| @| transparent| inherit).*;$";
string input = @"I want to capture all colors that are not ""transparent"", ""inherit"" or starts with an ""@"" character.
should be captured
--------------------------
color: blue;
color:red3434;
color: red3434;
color: #00FF00;
color: #F0F;
color: face(@B23);
should not be captured
--------------------------
color: transparent;
color:@transparent;
color: @transparent;
color:inherit;
color: @B23;";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}