import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^color:(?!@|transparent|inherit| @| transparent| inherit).*;$";
final String string = "I want to capture all colors that are not \"transparent\", \"inherit\" or starts with an \"@\" character.\n\n"
+ "should be captured\n"
+ "--------------------------\n"
+ "color: blue;\n"
+ "color:red3434;\n"
+ "color: red3434;\n"
+ "color: #00FF00;\n"
+ "color: #F0F;\n"
+ "color: face(@B23);\n\n"
+ "should not be captured\n"
+ "--------------------------\n"
+ "color: transparent;\n"
+ "color:@transparent;\n"
+ "color: @transparent;\n"
+ "color:inherit;\n"
+ "color: @B23;";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}