using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[body:\](.*?)(?=^\[body:\]|\Z)";
string input = @"[body:]asdasd
[body:]asdasdgdfg
[body:]asdasddf
[body:]asdasd
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}