re = /\[body:\](.*?)(?=^\[body:\]|\Z)/mi
str = '[body:]asdasd
[body:]asdasdgdfg
[body:]asdasddf
[body:]asdasd
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end