package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z]{1,10}$`)
var str = `1
a a
a
a1
abcdefjklj
abcdefjkljz`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}