$re = '/^[a-z]{1,10}$/m';
$str = '1
a a
a
a1
abcdefjklj
abcdefjkljz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);