using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.{8}$)(?:\d*[a-z]){2}\d*$";
string input = @"a123456b
1a2b3456
aa123456
123ab456
And the bad samples:
1abcdefg2
a1234567b
abcdefgh
12345678";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}