$re = '/^(?=.{8}$)(?:\d*[a-z]){2}\d*$/m';
$str = 'a123456b
1a2b3456
aa123456
123ab456
And the bad samples:
1abcdefg2
a1234567b
abcdefgh
12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);