package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(\d{0,4}\.?)*\.\d{2}?`)
var str = `0117.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}