$re = '/(\d{0,4}\.?)*\.\d{2}?/su';
$str = '0117.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);