package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\[\d+]\: )(?P<URL>.*)`)
var str = `![enter image description here][1] [1]: http://www.codefixup.com/wp-content/uploads/2016/09/pattern-matching-in-php.png`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}