const regex = /(?:\[\d+]\: )(?P<URL>.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[\\d+]\\: )(?P<URL>.*)', '')
const str = `![enter image description here][1] [1]: http://www.codefixup.com/wp-content/uploads/2016/09/pattern-matching-in-php.png`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}