package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[0-9]{1,2}-[0-9]{1,2}`)
var str = `99-34
0-94
04-8
9-8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}