$re = '/[0-9]{1,2}-[0-9]{1,2}/';
$str = '99-34
0-94
04-8
9-8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);