using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ca.\s*(\d+)\s*\-\s*(\d+)\s*(\w+)";
string input = @"4x 280.000 g
ca. 200-250g
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}