package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ca.\s*(\d+)\s*\-\s*(\d+)\s*(\w+)`)
var str = `4x 280.000 g
ca. 200-250g
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}