package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\[(.+?)\]\((https?:\/\/|ftp:\/\/|mailto:[^\)]+)\)`)
var str = `[Another link to Google](http://www.google.com), [a secure link to Google](https://www.google.com),
[Bad link to Google](www.google.com)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}