import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(.+?)\\]\\((https?:\\/\\/|ftp:\\/\\/|mailto:[^\\)]+)\\)";
final String string = "[Another link to Google](http://www.google.com), [a secure link to Google](https://www.google.com),\n"
+ "[Bad link to Google](www.google.com)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}