re = /(?:\?|\&)(?<key>[\w]+)(?:\=|\&?)(?<value>[\w+,.-]*)/
str = 'css?v=1.0&display=screen'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end