package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img.*?src="(.*?)"`)
var str = `<img size="6995" id="img570172" tabindex="0" data-outlook-trace="F:1|T:1" src="data:image/jpeg;base64,iVBORw0KGgoAAAANSUhEUgAAAQMAAADCCAMAAAB6zFdcAAACQFBMVEX///9NTU///v9CQkTzcCD/6wBKSkxFRUeEKZBAQEL/7gD+6AD///2HKJD/5QD/8QBJL5J2K5C1tbZ/KpFhLZFYLpBoLJCrKlE7Oz0Ae77r6+z6pxmsrK3+4QD/2QD/0QCoKVLi4uOdnZ4AfrukK1b9tRXzaQAAh7H"> <img size="6995" id="img570172" tabindex="0" data-outlook-trace="F:1|T:1" src="data:image/jpeg;base64,11111iVBORw0KGgoAAAANSUhEUgAAAQMAAADCCAMAAAB6zFdcAAACQFBMVEX///9NTU///v9CQkTzcCD/6wBKSkxFRUeEKZBAQEL/7gD+6AD///2HKJD/5QD/8QBJL5J2K5C1tbZ/KpFhLZFYLpBoLJCrKlE7Oz0Ae77r6+z6pxmsrK3+4QD/2QD/0QCoKVLi4uOdnZ4AfrukK1b9tRXzaQAAh7H"> <img size="6995" id="img570172" tabindex="0" data-outlook-trace="F:1|T:1" src="data:image/jpeg;base64,22222iVBORw0KGgoAAAANSUhEUgAAAQMAAADCCAMAAAB6zFdcAAACQFBMVEX///9NTU///v9CQkTzcCD/6wBKSkxFRUeEKZBAQEL/7gD+6AD///2HKJD/5QD/8QBJL5J2K5C1tbZ/KpFhLZFYLpBoLJCrKlE7Oz0Ae77r6+z6pxmsrK3+4QD/2QD/0QCoKVLi4uOdnZ4AfrukK1b9tRXzaQAAh7H">`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}