package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<city>[A-Z]{1,2})([^\S\r\n]|-)*(?<letters2>[A-Z]){1,2}[^\S\r\n]*(?<numbers>[0-9]{1,4})[^\S\r\n]*(?<suffix>E)?`)
var str = ` AB CD 1334E
A-CD 1334E
RZ-SN440 E
RZ - F4 E
RZ - F4223`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}