const regex = /(?<city>[A-Z]{1,2})([^\S\r\n]|-)*(?<letters2>[A-Z]){1,2}[^\S\r\n]*(?<numbers>[0-9]{1,4})[^\S\r\n]*(?<suffix>E)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<city>[A-Z]{1,2})([^\\S\\r\\n]|-)*(?<letters2>[A-Z]){1,2}[^\\S\\r\\n]*(?<numbers>[0-9]{1,4})[^\\S\\r\\n]*(?<suffix>E)?', 'gm')
const str = ` AB CD 1334E
A-CD 1334E
RZ-SN440 E
RZ - F4 E
RZ - F4223`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}