#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w(\d{1,})\.\w(\d{0,2})"
Local $sString = "B43.C21.D10.E110" & @CRLF & _
"B52.C21.D22.E000" & @CRLF & _
"B52.C21.D22.E000" & @CRLF & _
"B42.C11.D10.E120" & @CRLF & _
"B42.C11.D10.E120" & @CRLF & _
"B42.C11.D10.E120" & @CRLF & _
"B42.C11.D10.E120" & @CRLF & _
"B42.C11.D10.E120" & @CRLF & _
"B42.C11.D10.E120" & @CRLF & _
"B42.C11.D10.E120" & @CRLF & _
"B42.C11.D10.E120" & @CRLF & _
"B42.C11.D20" & @CRLF & _
"B42.C11.D20" & @CRLF & _
"B46.C71.D11.E000" & @CRLF & _
"B81.C21.D10.E000" & @CRLF & _
"B80.C20.D10.E000" & @CRLF & _
"B81.C10.D10.E000" & @CRLF & _
"B35.C11.D10.E116" & @CRLF & _
"B19.C20.D2" & @CRLF & _
"B81.C10.D10.E000" & @CRLF & _
"B80.C20.D10.E000" & @CRLF & _
"B46.C3" & @CRLF & _
"B36.C00.D11.E000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")