# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\w(\d{1,})\.\w(\d{0,2})"
test_str = ("B43.C21.D10.E110\n"
"B52.C21.D22.E000\n"
"B52.C21.D22.E000\n"
"B42.C11.D10.E120\n"
"B42.C11.D10.E120\n"
"B42.C11.D10.E120\n"
"B42.C11.D10.E120\n"
"B42.C11.D10.E120\n"
"B42.C11.D10.E120\n"
"B42.C11.D10.E120\n"
"B42.C11.D10.E120\n"
"B42.C11.D20\n"
"B42.C11.D20\n"
"B46.C71.D11.E000\n"
"B81.C21.D10.E000\n"
"B80.C20.D10.E000\n"
"B81.C10.D10.E000\n"
"B35.C11.D10.E116\n"
"B19.C20.D2\n"
"B81.C10.D10.E000\n"
"B80.C20.D10.E000\n"
"B46.C3\n"
"B36.C00.D11.E000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.