import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\d,]+\\h*x\\h*[\\d,]+\\h*x\\h*([\\d,]+)";
final String string = "| Matches/Cases | Result |\n"
+ "|-------------------|--------|\n"
+ "| 200 x 90 x 14 | 14 |\n"
+ "| 90x200 | - |\n"
+ "| 200 x 90x20 | 20 |\n"
+ "| 60,4 x46,5 x 42,6 | 42,6 |\n"
+ "| 90x190,9 | - |";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}