re = /[\d,]+\h*x\h*[\d,]+\h*x\h*([\d,]+)/
str = '| Matches/Cases | Result |
|-------------------|--------|
| 200 x 90 x 14 | 14 |
| 90x200 | - |
| 200 x 90x20 | 20 |
| 60,4 x46,5 x 42,6 | 42,6 |
| 90x190,9 | - |'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end