re = /(\$\d+)(.*Take ')(.*)(')/m
str = '
Example:
$250 \'Hello 1\' Take \'____\'
$500 \'Hello 2\' Take \'____\'
$1000 \'Hello 3\' Take \'____\''
subst = '\\1\\2\\1\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result