import Foundation
let pattern = #"(\$\d+)(.*Take ')(.*)(')"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Example:
$250 'Hello 1' Take '____'
$500 'Hello 2' Take '____'
$1000 'Hello 3' Take '____'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\2\1\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)