#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "&(?!&)"
Local $sString = "Ne&w && Edit Record"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)