use strict;
my $str = 'Ne&w && Edit Record';
my $regex = qr/&(?!&)/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";