#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(href=\")(.*?)(\.*?">)(.*?)(\*?<\/a>.*?.small">)([0-9]+)(.*?">)([0-9]+)(.*?strong>)([0-9]+ €) (.*[0-9].br>)(.*?)(\<br>)"
Local $sString = "<section class="rbr-aditem-main ad-listitem-main">" & @CRLF & _
" <h2><a class="ad-title" href="/anzeigen/s-anzeige/sofort-suhe-wohnung/353529866-203-16331">Sofort suhe Wohnung</a></h2>" & @CRLF & _
" <p>Wegen Wasserschaden sucht Ehepaar 2-3 Zimmerwohnung in Höchst und Umgebung ab sofort. Bis 750€ warm.</p>" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" <p>" & @CRLF & _
" <span class="badge-attribute rbr-tag rbr-tag-small">2 Zimmer</span>" & @CRLF & _
" <span class="badge-attribute rbr-tag rbr-tag-small">50 m²</span>" & @CRLF & _
" </p>" & @CRLF & _
"" & @CRLF & _
" </section>" & @CRLF & _
" <section class="rbr-aditem-details ad-listitem-details">" & @CRLF & _
" <strong>750 € VB</strong>" & @CRLF & _
" <br>" & @CRLF & _
" 65929<br>" & @CRLF & _
" Unterliederbach<br>" & @CRLF & _
" </section>" & @CRLF & _
" <section class="rbr-aditem-addon ad-listitem-addon">" & @CRLF & _
" Heute, 23:36</section>" & @CRLF & _
" </article>" & @CRLF & _
" </li>" & @CRLF & _
"" & @CRLF & _
" <li class="ad-listitem lazyload-item ">" & @CRLF & _
" <article class="rbr-aditem">" & @CRLF & _
" <section class="rbr-aditem-image ad-listitem-image">" & @CRLF & _
" <div data-href="/anzeigen/s-anzeige/altbau-im-nordend/353505098-203-4303" data-imgsrc="http://i.ebayimg.com/00/s/MTAyNFg3Njg=/z/CYIAAOSw~gRV13uh/$_9.JPG" data-imgtitle="Altbau im Nordend Frankfurt (Main) - Nordend Vorschau" class="rbr-imagebox srpimagebox"></div>" & @CRLF & _
" </section>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")