# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(href=\")(.*?)(\.*?\">)(.*?)(\*?<\/a>.*?.small\">)([0-9]+)(.*?\">)([0-9]+)(.*?strong>)([0-9]+ €) (.*[0-9].br>)(.*?)(\<br>)"
test_str = ("<section class=\"rbr-aditem-main ad-listitem-main\">\n"
" <h2><a class=\"ad-title\" href=\"/anzeigen/s-anzeige/sofort-suhe-wohnung/353529866-203-16331\">Sofort suhe Wohnung</a></h2>\n"
" <p>Wegen Wasserschaden sucht Ehepaar 2-3 Zimmerwohnung in Höchst und Umgebung ab sofort. Bis 750€ warm.</p>\n\n\n"
" <p>\n"
" <span class=\"badge-attribute rbr-tag rbr-tag-small\">2 Zimmer</span>\n"
" <span class=\"badge-attribute rbr-tag rbr-tag-small\">50 m²</span>\n"
" </p>\n\n"
" </section>\n"
" <section class=\"rbr-aditem-details ad-listitem-details\">\n"
" <strong>750 € VB</strong>\n"
" <br>\n"
" 65929<br>\n"
" Unterliederbach<br>\n"
" </section>\n"
" <section class=\"rbr-aditem-addon ad-listitem-addon\">\n"
" Heute, 23:36</section>\n"
" </article>\n"
" </li>\n\n"
" <li class=\"ad-listitem lazyload-item \">\n"
" <article class=\"rbr-aditem\">\n"
" <section class=\"rbr-aditem-image ad-listitem-image\">\n"
" <div data-href=\"/anzeigen/s-anzeige/altbau-im-nordend/353505098-203-4303\" data-imgsrc=\"http://i.ebayimg.com/00/s/MTAyNFg3Njg=/z/CYIAAOSw~gRV13uh/$_9.JPG\" data-imgtitle=\"Altbau im Nordend Frankfurt (Main) - Nordend Vorschau\" class=\"rbr-imagebox srpimagebox\"></div>\n"
" </section>")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.