$re = '//.*/.*/.*/.*//';
$str = '/a1/a2/a3/a4/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);