#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^elasticmapreduce\/j-.*\/node\/i-.*\/(?!(applications(\/.*)*))"
Local $sString = "elasticmapreduce/j-abc123/node/i-abc123/applications/hadoop-yarn/hadoop-yarn-proxyserver-ip.log.2020-05-07-00.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/applications/hadoop-yarn/hadoop-yarn-timelineserver-ip.out.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/applications/hadoop-yarn/hadoop-yarn-proxyserver-ip.log.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/applications/hive/user/hive/hive.log.2020-05-07.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/applications" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/bootstrap-actions/master.log.2020-05-07-00.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/bootstrap-actions" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/daemons/instance-state/instance-state.log-2020-05-08-13-30.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/daemons/setup-dns.log.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/provision-node/abc123/stderr.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/provision-node/apps-phase/0/abc123/stderr.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/provision-node/reports/0/abc123/ip.ec2.internal/201805270306.yaml.gz" & @CRLF & _
"elasticmapreduce/j-abc123/node/i-abc123/setup-devices/setup_var_log_dir.log.gz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")