import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^elasticmapreduce\\/j-.*\\/node\\/i-.*\\/(?!(applications(\\/.*)*))";
final String string = "elasticmapreduce/j-abc123/node/i-abc123/applications/hadoop-yarn/hadoop-yarn-proxyserver-ip.log.2020-05-07-00.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/applications/hadoop-yarn/hadoop-yarn-timelineserver-ip.out.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/applications/hadoop-yarn/hadoop-yarn-proxyserver-ip.log.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/applications/hive/user/hive/hive.log.2020-05-07.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/applications\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/bootstrap-actions/master.log.2020-05-07-00.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/bootstrap-actions\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/daemons/instance-state/instance-state.log-2020-05-08-13-30.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/daemons/setup-dns.log.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/provision-node/abc123/stderr.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/provision-node/apps-phase/0/abc123/stderr.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/provision-node/reports/0/abc123/ip.ec2.internal/201805270306.yaml.gz\n"
+ "elasticmapreduce/j-abc123/node/i-abc123/setup-devices/setup_var_log_dir.log.gz";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}