re = /^\.?(?:(?:\d{1,3}[,. ])*\d{1,3}(?:\.\d{2})?|\d+\.\d+|\d+)\.?$/m
str = '.2.4.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end