#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:: *[^:\s]*[^:]*: *)+$"
Local $sString = ":foo::bar:" & @CRLF & _
":foo:" & @CRLF & _
":foo: :bar::test:" & @CRLF & _
":foo: :bar: :test:" & @CRLF & _
"" & @CRLF & _
":foo:something:bar:" & @CRLF & _
":foo:something" & @CRLF & _
"some :bar:" & @CRLF & _
":foo: some:bar: thing" & @CRLF & _
"" & @CRLF & _
" : : : : "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")