$re = '/^(?:: *[^:\s]*[^:]*: *)+$/m';
$str = ':foo::bar:
:foo:
:foo: :bar::test:
:foo: :bar: :test:
:foo:something:bar:
:foo:something
some :bar:
:foo: some:bar: thing
: : : : ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);