import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "url\\(\"images\\/";
final String string = ".ui-widget-content {\n"
+ " border: 1px solid #aaaaaa;\n"
+ " background: #ffffff url(\"images/ui-bg_flat_75_ffffff_40x100.png\") 50% 50% repeat-x;\n"
+ " color: #222222;\n"
+ "}\n"
+ ".ui-widget-content a {\n"
+ " color: #222222;\n"
+ "}\n"
+ ".ui-widget-header {\n"
+ " border: 1px solid #aaaaaa;\n"
+ " background: #cccccc url(\"images/ui-bg_highlight-soft_75_cccccc_1x100.png\") 50% 50% repeat-x;\n"
+ " color: #222222;\n"
+ " font-weight: bold;\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}