import re
regex = re.compile(r"url\(\"images\/")
test_str = (".ui-widget-content {\n"
" border: 1px solid #aaaaaa;\n"
" background: #ffffff url(\"images/ui-bg_flat_75_ffffff_40x100.png\") 50% 50% repeat-x;\n"
" color: #222222;\n"
"}\n"
".ui-widget-content a {\n"
" color: #222222;\n"
"}\n"
".ui-widget-header {\n"
" border: 1px solid #aaaaaa;\n"
" background: #cccccc url(\"images/ui-bg_highlight-soft_75_cccccc_1x100.png\") 50% 50% repeat-x;\n"
" color: #222222;\n"
" font-weight: bold;\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")