import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\/tempban (?:-s )?([A-Za-z0-9_]{3,16}) ([\\d.]+) *(s|seconds|m|minutes|h|hours|d|days|w|weeks|mo|months|years) (.*)$";
final String string = "/tempban networkException 1 mo pls work this time\n"
+ "/tempban networkException 1s testing again\n"
+ "/tempban -s networkException 1s testing again";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}