use strict;
my $str = '/tempban networkException 1 mo pls work this time
/tempban networkException 1s testing again
/tempban -s networkException 1s testing again';
my $regex = qr/^\/tempban (?:-s )?([A-Za-z0-9_]{3,16}) ([\d.]+) *(s|seconds|m|minutes|h|hours|d|days|w|weeks|mo|months|years) (.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}