package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(90|[0-8][0-9]?)$`)
var str = `1
43
568
90
89
32
356
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}