re = /^\g<body>$(?<body>(?:[^\()]|\g<parens>)*){0}(?<parens>\(\g<body>\)){0}/
str = '() 90\\()(())'
# Print the match result
str.match(re) do |match|
puts match.to_s
end