// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^\g<body>$(?<body>(?:[^\()]|\g<parens>)*){0}(?<parens>\(\g<body>\)){0}").unwrap();
let string = "() 90\\()(())";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}