const regex = /(^.*?)\Ktrue/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^.*?)\\Ktrue', 'gm')
const str = `Log date 12/12/2015
Sr No desc amount status
1 true \$10000 true
2 true \$10000 false
3 true \$10000 true
4 true \$10000 false
5 true \$10000 true`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}