re = /(^.*?)\Ktrue/m
str = 'Log date 12/12/2015
Sr No desc amount status
1 true $10000 true
2 true $10000 false
3 true $10000 true
4 true $10000 false
5 true $10000 true'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end